Settlement Processing Delay

Incident Report for Jaris

Resolved

All delayed payments have been processed and Jaris has returned to normal operations.
Posted Feb 02, 2026 - 15:05 UTC

Monitoring

A fix has been implemented and payments are beginning to process. Affected customers should begin seeing balances reach their accounts in the next few minutes.
Posted Feb 02, 2026 - 15:02 UTC

Identified

Jaris has identified the cause of the processing delay and are working with upstream vendors make repairs. We will provide an update in the next 30 minutes.
Posted Feb 02, 2026 - 14:52 UTC

Investigating

Jaris is currently investigating the source of a delay in processing customer settlements and will provide more information in about 30 minutes.
Posted Feb 02, 2026 - 14:39 UTC
This incident affected: API.