This incident has been resolved and payment processing is back to normal.
Posted Apr 15, 2026 - 13:08 UTC
Update
The upstream vendor has restored access to the Federal Reserve Network and all operations are back to normal. Jaris is continuing to monitor for any further issues.
Posted Apr 15, 2026 - 00:05 UTC
Monitoring
All outstanding payments have been processed via the alternative network and systems are back to normal operation. Jaris is continuing to wait for the upstream vendor to restore access to the Federal Reserve Network but there are no further impacts to the Jaris system at this time and we are going to continue to run in this alternative network arrangement while the upstream vendor continues their resolution efforts.
Updates will shift from every 30 minutes to as new information becomes available, however there are no remaining impacts to the Jaris platform.
Posted Apr 14, 2026 - 23:35 UTC
Update
Jaris has shifted to an alternate payment network and processed all outstanding merchant settlements while the upstream vendor continues to restore access to the Federal Reserve Network. Impacted loan payments are beginning to process across this alternative network.
Posted Apr 14, 2026 - 23:19 UTC
Update
An upstream vendor is continuing to work on restoring connectivity to the Federal Reserve Network. Affected Jaris payments are staged awaiting restoration of service.
Posted Apr 14, 2026 - 22:31 UTC
Identified
An upstream vendor is working to restore connectivity to the Federal Reserve Network.
Posted Apr 14, 2026 - 21:58 UTC
Update
We are continuing to investigate this issue.
Posted Apr 14, 2026 - 21:26 UTC
Investigating
Jaris has detected Settlement processing times increasing for some customers. We are investigating the incident and will provide updates as soon as possible.
Posted Apr 14, 2026 - 21:21 UTC
This incident affected: API and Applications (FastTrack, Jaris Connect).