Settlement Processing Times Increasing

Incident Report for Jaris

Resolved

Jaris has returned to normal Settlement processing timelines.
Posted Mar 02, 2026 - 14:49 UTC

Monitoring

The processing delay has resolved and the Settlement system has caught up.
Posted Mar 02, 2026 - 14:36 UTC

Investigating

Jaris monitoring has detected Settlement processing times increasing for some customers. We are investigating.
Posted Mar 02, 2026 - 14:27 UTC
This incident affected: API.