Payment Operation Errors

Incident Report for Jaris

Resolved

Recovery has completed and payment operations have returned to normal. Customers can resume normal payment operations.
Posted Nov 12, 2025 - 18:36 UTC

Monitoring

The upstream vendor has resolved the underlying connectivity issues and is recovering. Jaris is continuing to monitor the platform for any residual impacts.
Posted Nov 12, 2025 - 18:23 UTC

Investigating

An upstream vendor is experiencing connectivity issues that are intermittently impacting the ability to initiate payment operations. Customers can safely retry payment operations while we continue to monitor the situation.
Posted Nov 12, 2025 - 17:59 UTC
This incident affected: API and Applications (FastTrack, Jaris Connect).